The process could not bulk copy into table "dbo"."MSmerge_contents". Field size too large.
(too old to reply)
2007-12-18 20:09:39 UTC
I am getting the following error when trying a merge replication:
The process could not bulk copy into table "dbo"."MSmerge_contents".
Field size too large.

I assume that the "field size too large" is significant but I do not
know what it is referring to and it seems completely out of my

All the snapshot files download fine, it applies the .sch and .cft
files, bulk copies data into the main database tables and then says
that "the merge process was unable to deliver the snapshot to the
subscriber" and follows on with the error message above.

Some details:
publisher/distributor: SQL Server 2005 (workgroup edition)
subscriber: SQL Server 2005 Express
merge replication with web synchronisation
parameterised row filters used with (potentially) overlapping

The whole thing was working fine but I have been working on producing
a deployment package so I detached the database on the subscriber and
used the mdf file as the basis for the deployment (I have a feeling
that is the root cause of my problems). As part of the deployment I
copy in this mdf file (not the log file), attach using CREATE DATABASE
with the FOR ATTACH_REBUILD_LOG option. I also have various scripts in
the deployment to configure everything.

I have tried re-inititialising at the publisher and recreating the
snapshot but still the same error.

Any help greatly appreciated on this and any better way of setting up
the initial database before first synchronisation.
2007-12-18 20:36:03 UTC
On 18 Dec, 20:09, JDS <***@jeremysage.com> wrote:
I have just tried another subscriber that was previously working
perfectly and this has come up with errors; firstly that I needed to
reinitialise the subscription (amongst other error messages related to
metadata on the publisher) and then when I tried that, the same error
message as in the first post.

It looks like I have managed to mess up something on the publisher. It
would be good to know what (and how it happened) so I don't do it
again and if there is any way of repairing it other than dropping the
publication and recreating it.

Thanks in advance for any help.
Marcelo Miorelli
2012-10-10 15:55:54 UTC
today is 10-OCT-2012 and I am having the exactly same error.
I wonder if you managed to sort it out, and how you did it.
there is no much information available for this error, however, it seems to be a common one.

The process could not bulk copy into table "dbo"."MSmerge_contents". Field size too large

thanks in advance